El teu blog de Linux en català

Divendres de jocs: Temple of Tangram

Avui us proposem un joc que consisteix a omplir els espais buits amb unes peces de diferents mides. Vaja, un trencaclosques. Es tracta de Temple of Tangram.

A Temple of Tangram partireu d’unes peces força senzilles (quadrats, triangles, romboides, etc.) i els haureu d’anar girant (per mitjà del botó dret del ratolí) i col·locar-los de manera que s’omplin tots els espais. A més, en algunes de les pantalles el joc ens imposarà algunes dificultats, com el fet que, si tardem molt a posar una peça se’ns en tregui una altra ja col·locada o no poder veure on hem deixat les peces anteriors.

Pantalla inicial del Temple of Tangram

Pantalla inicial del Temple of Tangram

Per jugar al Temple of Tangram només cal que aneu a la seva pàgina principal i us baixeu el joc per a Linux. Un cop descarregat, descomprimiu el fitxer i us deixarà un altre fitxer anomenat «TempleOfTangram». Feu-hi doble clic, i el joc se us obrirà directament.

Pantalla de joc del Temple of Tangram

Pantalla de joc del Temple of Tangram

El joc, en total, té 250 pantalles, però de forma gratuïta només tindreu accés a les primeres 50 (que ja estan molt bé). Si voleu accedir a la resta de nivells, en el propi joc hi ha un enllaç per poder pagar els 4 € que costen.

    • Joan on 21 de Febrer de 2011 at 19:55

    Reply

    Hola Oriol! Tenia curiositat pel joc, però a l’hora d’executar-lo no se m’obra. He provat de cridar-lo des de la terminal i em retorna “violació de segment”. Saps a què es pot deure?

    Gran secció la de divendres de jocs. Feu una feina admirable!

    • oriolsbd on 22 de Febrer de 2011 at 21:50
    • Author

    Reply

    Ostres. L’error que comentes normalment és intern al programa. Si no recordo malament, el programa intenta escriure en una zona de memòria on no li tocaria. No hi ha gaire més remei que avisar el programador que ha passat aquest problema. Quina distribució tens, i quina versió? 32 o 64 bits?

    Salut!

      • Joan on 23 de Febrer de 2011 at 20:51

      Reply

      L’ordinador em funciona amb Ubuntu versió 10.10 de 64 bits. He vist que en principi ja ve preparat per executar-se com a programa; és més, en executar-lo, es crea una carpeta anomenada data al mateix directori, però d’aquí no passa. He estat buscant gent amb problema similar i no he trobat ningú. Dec tenir quelcom malament. Tampoc és quelcom crucial però; sort que de moment encara em queden moltes estones de vici amb el warmux :D.

      Gràcies per la teva resposta.

        • oriolsbd on 23 de Febrer de 2011 at 21:15
        • Author

        Reply

        Jo estic utilitzant exactament la mateixa versió (Ubuntu 10.10 de 64 bits). He vist que el fitxer en realitat és un executable de 32 bits. Hauria de funcionar (com et dic, a mi em va), però serà una mica difícil veure’n el motiu. Mira que tinguis instal·lat el paquet «ia32-libs». Suposo que sí, però és per assegurar.

          • Joan on 23 de Febrer de 2011 at 21:43

          Reply

          Potser va per aquí el problema. El paquet sí que el tinc instal·lat, però fa res que aquest paquet em va provocar un problema de dependències, perquè crec que el wine 1.3 per una banda necessitava una versió mentre que d’altres programes dependents n’exigien una altra. Crec que va anar així. El vaig reinstal·lar i ja no es va queixar més i per això ja no li vaig prestar més atenció, però no m’estranyaria que s’hagués perdut “alguna cosa” pel camí.

          Gràcies de nou, Oriol.

    • Mianda on 23 de Febrer de 2011 at 12:35

    Reply

    I adore such games. They weaken after work. And if to play with a friend it is funny

Deixa un comentari

Your email address will not be published.